安装

一般说明

安装hi-nginx的方式,就是编译安装nginx的方式。只是多个几个配置选项:

                --enable-http-hi-cpp=YES                            \
                --enable-http-hi-python=YES                         \
                --enable-http-hi-lua=YES                            \
                --enable-http-hi-java=YES                           \
                --enable-http-hi-php=YES                            \
                --with-http-hi-python-version=python3               \
                --with-http-hi-lua-version=lua5.3                   \
                --add-module=ngx_http_hi_module

五种语言中除c++外,均为可选的。所有语言支持均由模块ngx_http_hi_module提供。因此,必须通过--add-module添加该模块。

不需要哪种语言,就把相关enable项设置为NO。

同时,对于lua和python来说,它们还可以选择支持的版本。对lua而言,可选lua,lua5.x或者luajit。对python而言,可选python2或者python3。

依赖

  • linux,hi-nginx暂不支持windows系统
  • gcc 和 g++(c++11) 或者 clang 和 clang++
  • hiredis-devel
  • python-devel,如果 --enable-http-hi-python=YES 并且 with-http-hi-python-version=python2
  • python3.x-devel 如果 --enable-http-hi-python=YES 并且 with-http-hi-python-version=python3
  • lua-devel(lua5.1,5.2,5.3),如果 --enable-http-hi-lua=YES 并且 --with-http-hi-lua-version=lua5.x
  • luajit-devel,如果 --enable-http-hi-lua=YES 并且 --with-http-hi-lua-version=luajit
  • jdk,如果 --enable-http-hi-java=YES
  • PHP 7.0+(--enable-embed=shared),如果 --enable-http-hi-php=YES

关于php7支持

要安装php7支持,需要编译安装php7时添加--enable-embed=shared配置选项。这是必须的。另外,php7源码包中configure脚本需要略略的修改下。找到该脚本中的以下段落:

ac_fn_c_check_decl "$LINENO" "isfinite" "ac_cv_have_decl_isfinite" "#include <math.h>
"
if test "x$ac_cv_have_decl_isfinite" = xyes; then :
  ac_have_decl=1
else
  ac_have_decl=0
fi

把第一等于1的等式改为等于0即可。

编译安装完成php7后,配置下php.ini文件,假设hi-nginx将安装在/usr/local


include_path = ".:/usr/local/nginx/php"

如果hi-nginx将安装在其他地方,需要相应地修改下上面的值。

如果有必要,还需把libphp7.so所在的路径添加到/etc/ld.so.conf.d/php.conf中。

关于java支持

强烈建议使用java版本不低于 1.8。

最简单方法是直接安装openjdk-devel,如果不怕麻烦,用oracle的也可以的。关键是设置$JAVA_HOME和java搜索路径,否则编译hi-nginx时无法找到相关java库和头文件。可以在/etc/ld.so.conf.d下新建一个文件java.conf,

  • 对9以下版本,内容如下:

          $JAVA_HOME/lib/
          $JAVA_HOME/lib/server
    
  • 对9版本,内容如下:
          $JAVA_HOME/jre/lib/amd64/server
    
    上面的$JAVA_HOME变量务必替换为该变量的真实值。然后记得sudo ldconfig

关于javascript支持

hi-nginx对javascript的支持是跟其对java的支持同步完成的。

关于javascript服务器端开发,人们首先和唯一想到的几乎都是node.js。

是的,node.js很棒!

但是hi-nginx比node.js更棒!!。

hi-nginx实现的是java+javascript的模式,而不是v8+javascript。虽然号称v8是最好的javascript引擎,但是hi-nginx走一个mustache.js渲染都比node.js的"hello,world"快至少2倍,而且极为稳定。

实际上,hi-nginx对javascript的支持是通过javax.script.ScriptEngine实现的。这种实现有两种方式,第一种是在java层,第二种是走jni。两种都是可行的。在hi-nginx-demo项目中,我给出了一个基于java层的简单实现。在hi-nginx项目中采用的基于jni实现。这种实现的好处是能够充分利用c/c++的优势降低JVM对内存的消耗,而且可以获得更高的性能表现。

更重要的是,因为可以利用javax.script.ScriptEngine接口,所以任何实现JSR-223的基于JVM的脚本语言,都是可以直接支持的,例如groovy和kotlin——当然需要安装相关语言并正确设置配置。比如gooovy:


        hi_java_classpath "-Djava.class.path=.:/usr/local/nginx/java:/usr/local/nginx/java/hi-nginx-java.jar:/usr/local/groovy-2.5.0/lib:/usr/local/groovy-2.5.0/lib/groovy-2.5.0.jar:/usr/local/groovy-2.5.0/lib/groovy-jsr223-2.5.0.jar";

        location / {
                hi_need_cache off;
                hi_cache_expires 5s;
                hi_need_kvdb on;
                hi_kvdb_size 10;
                hi_kvdb_expires 5m;
                hi_need_cookies on;
                hi_need_headers on;
                hi_need_session on;
                hi_session_expires 300s;
                hi_javascript_compiledscript_expires 5m;
                hi_javascript_lang groovy;
                hi_javascript_extension groovy;
                hi_javascript_script groovy/index.groovy;
                #hi_javascript_content "hi_res.content='hello,world.';hi_res.status=200";
        }

有一点必须指出:如果你需要运行多种jsr-223的JVM语言,比如javascript和groovy,那么由于JVM是进程级的,每个进程只有一个JVM,且只会初始化一次,所以为了确保多种JVM语言能够同时运行,需要确保JVM初始化时的hi_java_classpath指令参数能够同时为多种语言所用。比如,单单运行javascript,不需要跟groovy有关的配置,但是若同时需要运行groovy,则需要添加相关配置。

由于java本身对javascript的极好支持,使得在hi-nginx中,可以直接在javascript脚本中使用java——相当于把java嵌入了javascript。因此,你随时可以用java写个库或者类,然后在javascript中随便玩。这比用c/c++写node.js扩展舒服多了。

最后再强调一次,在hi-nginx中运行javascript服务器端应用,其性能比node.js要高得多,高得多,高得多!!!

results matching ""

    No results matching ""